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�
Introduction





The information in this Application Note applies to Microsoft Word versions 6.x for Windows, Microsoft Word versions 6.0 and 6.0.1 for the Macintosh®, Microsoft Word version 6.0 for Windows NT™, and Microsoft Word version 7.0 for Windows 95.





What Is a Prank Macro?





A prank macro is a harmless but annoying macro. This Application Note will help you clean up and prevent further annoyance caused by a particular prank macro that replicates itself in Word.





What Are the Symptoms?





With the prank macro in question, document content remains intact and is not changed in any way. The macro copies itself into the Normal template and then repli�cates itself into new files, which it saves as templates. 





The macro has several symptoms:





When you try to save a new document, Word only lets you save the document as a template.





When you open an affected document, a dialog box showing the number 1 appears (see Figure 1).
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Figure 1: This dialog box appears when you open an affected document. 





New macros named AAAZAO, AAAZFS, and PayLoad appear in the list of macros. AutoOpen and FileSaveAs macros also appear; if you already had macros by these names, the prank macro changes their contents.





What Does the Scan831.doc File Do?





When you open Scan831.doc, the file included with this Application Note, it checks your installation of Word to see if the prank macros are present in your Normal template. If Word finds the offending macros, Word removes them and installs another macro to prevent future installation of the prank macro. 





The following macros are installed in your Normal template when you open Scan831.doc.





This macro�
Does this�
�
�
�
�
AutoClose�
Scans for evidence of the prank macros as you close documents. If evidence is found, AutoClose removes the added macros from the affected document. 


�
�
PayLoad�
Helps prevent reinstallation and spreading of the prank macro.�
�



Scan831.doc also includes a macro called CleanAll, which runs automatically when you open the Scan831.doc file. CleanAll scans a specific folder and all subfolders (if selected), opens each document and template in the search path that was saved after January 1st, 1995, checks for evidence of the prank macro, and removes the added macros if found.


If you want to run the CleanAll macro again to clean other paths, click Macro on the Tools menu, select CleanAll in the Macro Name list, and click Run. You can also copy the CleanAll macro from Scan831.doc to the Normal template by using the Organizer. (To locate the Organizer, click Macro on the Tools menu, and then click the Organizer button.)








To install the appropriate files to your hard disk (Word for Windows)





1.	If you received a disk with this Application Note, insert the disk in the appropriate floppy disk drive.





If you downloaded this Application Note from an online service, skip to step 2. This procedure assumes that you have already downloaded and extracted the compressed file.





2.	At the MS-DOS prompt, type the following and press enter





copy source:\Scan831.doc location





where source is either the letter of your floppy disk drive or the folder (directory) containing the file you downloaded from online services, and location is the path to your Wordfolder. For example, if you are copying the file from a floppy disk that you inserted in drive A, and C:\Winword is the path to your Word folder, type:





copy a:\Scan831.doc c:\winword





Or, for example, if you downloaded the Wd1215.exe file from online services to C:\Dnload, and C:\Ww is the path to your Word folder, type:





copy c:\dnload\Scan831.doc c:\ww





To install the appropriate files to your hard disk (Word for the Macintosh)





1. 	If you received a disk with this Application Note, insert the disk in the appropriate floppy disk drive.





If you downloaded this Application Note from an online service, skip to step 2. This procedure assumes that you have already downloaded and extracted the compressed file.





2. 	Open the disk or folder.





3. 	Drag Scan831.doc from the disk or folder to the folder that contains your Word program.





To find and fix affected documents





1.	Close any documents that are open in Word.





Note: If you are using Windows 95, clear the Start Documents menu before you run the macro. If you neglect to clear the Documents menu, and the Documents folder contains shortcuts to documents, the macro will try to follow the shortcuts to their origins, which can cause problems if the location is no longer available. To clear the Start Documents menu, use the following steps:





a.	With the right mouse button, click the Windows 95 Taskbar.





b.	Click Properties, and then click the Start Menu Programs tab.





c.	Under Documents Menu, click Clear.





2.	In Word, on the File menu, click Open.





3.	In the File Name box, type 





winword\Scan831.doc





where winword is the path to your Word folder (usually C:\Winword).





4.	Click OK (in Word 6.0) or Open (in Word 7.0).





When you open Scan831.doc, the AutoOpen macro runs automatically and checks your Normal template for evidence of the prank macro. If evidence is found, AutoOpen deletes the added macros and leaves a macro named PayLoad in their place.





Next, AutoOpen runs the CleanAll macro, which allows you to scan and clean existing files on your system or on a network share.





If you want to run the CleanAll macro a second time to scan and possibly clean a different set of files, follow these steps:





To run the CleanAll macro





1.	On the Tools menu, click Macro.





2.	In the Macro Name list, click CleanAll. Click Run.


The Batch Macro Cleanup dialog box appears.





�


Figure 2: The Batch Macro Cleanup dialog box





3.	In the Directory box, type the path to the folder (directory) in which you want Word to start checking. 





4.	Click OK.





Word searches all the documents and tem�plates in this folder and its subfolders.





Note: The scanning process may take an ex�tended amount of time, depending on the size of your hard disk and the num�ber of documents and templates the process has to scan.





Notes on the CleanAll Macro





In Word for Windows 95, version 7.0, you won't see a dialog box that shows the current status during the first part of the macro's search. 





The macro may be temporarily interrupted and it may prompt you for infor�mation if it encounters documents or templates with any of the following characteristics (this behavior is normal):





ASK fields in the header





AutoOpen macros that require user interaction





Main mail merge documents when the at�tached data file cannot be located





Passwords





Links to other documents


Note: To prevent messages related to links, click Options on the Tools menu, click the General tab, and clear the "Update Automatic Links At Open" check box.





More Information: All Platforms of Word





Close all other documents before opening Scan831.doc.


When the CleanAll portion of the SCAN831 tool runs, it opens and closes all eligible documents. SCAN831 may close documents that are currently opened. To ensure you do not lose any work, close all other documents before opening Scan831.doc or running CleanAll.





Prompt to convert template back to document.


Part of the prank in the prank program is to change documents into document templates. This creates a problem with the File Save As command. When CleanAll finds a file that contains evidence of the prank macro, CleanAll removes the added macros and prompts for confirmation to convert the template back to a document. This prompt appears only if the file has no additional macros, AutoText entries, or key assignments. While these internal tests are good indications that the template should be converted back to a document, there are other possible reasons that the file should remain a template. Because of these reasons, user confirmation is required to make the change.





Error Message: “WordBasic Error 53 - File Not Found.” 


The most likely reason for this error is in the rare case when the AutoOpen macro cannot locate the Normal template file. This might happen if your User Templates path does not contain the Normal template used by your Word session. Be sure that this setting points to the correct location of your Normal template. (To locate the User Templates setting, click Options on the Tools menu, and click the File Locations tab.)





Error Message: “The list of paths is full.” 


While scanning a large directory structure with many files, you may encounter the message  “The list of paths is full.”  This message indicates that Word for Windows cannot deal with the number of documents found. To work around this problem, scan smaller subdirectory structures or individual subdirectories by themselves (that is, clear the Scan Subdirectories check box [see Figure 2]).





Screen flashes when macros are run.


When Internet Assistant is installed, you may notice a some flashing on the screen as the CleanAll macro opens and closes documents. 





File cannot be opened.


If a file cannot be opened or saved, there may be insufficient permissions or an incorrect password, or another user may have the file open.





Converter or style sheet cannot be found.


When CleanAll opens a document, you may get an error message indicating that a converter or style sheet could not be found. You can ignore this error message; most likely, the document was created with an earlier version of Word for Windows, Word for the Macintosh, or Word for MS-DOS.





Not all documents are found.


The CleanAll macro searches only for those files that have a save date later than January 1, 1995. The reason for this is that evidence of the prank macro was  first encountered well into mid-1995.








More Information: Word for Windows 95





During the first cycle of the CleanAll macro, you will not see the dialog box showing the current status of the search.








More Information: Word for the Macintosh





In Word for the Macintosh, the Directory box in the Batch Macro Cleanup dialog box (see Figure 2) shows Macintosh HD as the default. If your hard disk has a different name, you'll need to remove the "Macintosh HD:" text and type the name of your hard disk instead.





Questions and Answers





1.	Q.	Which versions of Word are affected by this problem? 





A.	The macro affects all versions of Word that use the Word 6.0 template format. The scanning tool works across all plat�forms and versions of Word that are potentially affected.





2.	Q.	Can the prank macro be transferred over the Internet? What about my WordMail messages?





A.	No, the prank macro does not travel freely over the Internet; it can only be transferred when a user opens a document or tem�plate that contains the prank macro. Also, the prank macro cannot be transported in any message sent using WordMail, unless the message contains an embedded document that you open.





3.	Q.	Is my document content okay? Should I worry about losing files?





A.	Documents remain intact. The prank macro is more a minor annoyance than anything that can truly harm your work.





4.	Q.	Can this same type of prank macro be transferred with documents created with or being read by Internet Assistant?





A.	Internet Assistant and documents created or read by it are not affected by such pranks. Internet Assistant, by design, blocks the mechanism that distributes these prank macros. 





5.	Q.	How can I protect myself against this type of prank in the future?





A.	One way to prevent this type of prank from tampering with Word is to hold down the shift key when you open a template or document. This prevents Auto macros from loading when you start Word.�
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