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Please read this entire document for important information about the Scan tool, including problems you may encounter when running it.





This document contains the following:


Questions and answers about the Word prank macros


Information about the Scan tool (the Scan tool is part of this document).





Information on the Word Prank Program


Microsoft was recently made aware of a prank program that distributes itself through Word and tampers with users’ Save As command. Although the prank program does not affect any document content, Microsoft now provides a scanning tool that ensures our customers are no longer inconvenienced by the program and provides them with a long-term solution for protecting their files and system against it. 





The Scan Tool


This document contains cleanup macros that do the following:


Remove prank macros from Normal template


Install a protective macro preventing the installation of the prank macro


Offer the option of scanning the hard drive for documents containing the prank macros 


Detect documents affected by the prank macros





Simply open this document to begin the scanning process.





NOTE: The scanning process may take an extended amount of time depending on the size of your hard drive and the number of documents and templates the process has to scan. Also, Word may prompt you at various times when the document it is trying to open contains a link to a data source requires a password, or contains the prank macros.





Q&A 


Q:  What is the Word prank Macro? 


A:  Microsoft® Word is a target of a prank macro which distributes itself through documents created in Word 6.0 for Windows® 3.1, Word 6.0.1 for the Macintosh®, Word 6.0 for Windows NT™ and Word for Windows 95.  The prank macro does not affect earlier versions of Word for Windows or Word for the Macintosh.  After you open a document containing the macro, documents you save will contain copies of the macro.  Once installed, the macro only lets you save documents as templates.  The macro does not otherwise affect the contents of the document. 





Q: 	How do I know whether or not I have encountered the prank program?


A:  	You can tell if your copy of Word has been affected by the prank program if you open a document and a Microsoft Word dialog box appears that contains “1” as the only text. Another way to tell is to click Macro on the Tools menu and see if the Macro Name list contains the following five macros: AAAZAO, AAAZFS, PayLoad, AutoOpen, and FileSaveAs. If all five of these macros appear in the list, your copy of Word has been affected by the prank program.





Q:  How serious is the Prank Macro and what is the worst thing that could happen? 


A:  	The macro does not cause data loss or any other serious system corruption, but is an annoyance.  However, if your system is affected, the File Save As command in Word will cause your documents to be saved as templates containing the Prank Macro.





Q:  Will a box of Word or Office that I buy in the store contain this Prank Macro? 


A:  	The Prank Macro does not exist in any version of Word or Office that you would buy in a store.  You can only get the Prank Macro by opening a Word document or template that already contains the macro. 





Q.  Who created this Prank Macro and how would I get it? 


A.  	We do not know who created the Prank Macro.  The macro is transferred when a user opens a document or template that contains the Prank Macro. The Prank Macro does not travel freely over the Internet, nor can it be transported in any message sent using WordMail, unless the message contains an embedded document that the recipient opens. 





Q:  	Can the prank program be transferred over the Internet? What about my WordMail messages?


A:  	No, the prank program does not travel freely over the Internet; it can only be transferred when a user opens a document or template that contains the prank program.  Also, the prank program cannot be transported in any message sent using WordMail, unless the message contains an embedded Word document object that the recipient opens.





Q:  	Can this same type of prank program be transferred with documents created with or being read by Internet Assistant?


A:  	Internet Assistant and documents created or read by it cannot be affected by such pranks. Internet Assistant, by design, blocks the mechanism that distributes them. 





Q:  Can I prevent getting the Prank Macro? 


A:  There are two methods to prevent getting the Prank Macro. You can install the scanning tool and it will prevent you from getting the Prank Macro in the future.  You can also disable the mechanism that allows the macro to install itself by holding down the shift key when opening a template or document.





Q: 	When I try to save the Scan Tool document by choosing “Save As” from the File menu, I can only save it as a template. Does that mean the Scan Tool document contains the prank macros?


A:	No. The Scan Tool document is actually a Word template that stores the macros that scan and clean your Word installation and documents. It is normal Word behavior to offer only the template option in the Save As dialog box when your current document is actually a template.





Q:	What’s the best way for me to be sure the Scan Tool has been successful in removing the Prank Macros?


A:	The best way is to see if you have the macros “AAAZFS” and “AAAZAO” still listed in the Macro Name dialog when you choose Macro from the Tools menu. The other way is to create a brand new document by clicking on the “New” button on the standard toolbar, then choose Save As from the File menu. If the “Save as type” field says “Document Template” then the Scan Tool was not successful. Close the Scan Tool document, exit Word, restart Word, then open the Scan Tool document again to re-run the prank macro detection and cleaning process.





Information on the Scan Tool





When you open this document (Scan831.doc), an AutoOpen macro runs that checks your Word installation for the presence of the prank macros. If any prank macros are found, the AutoOpen macro disables them.. The Scan tool installs the following  macros in your Normal template:





Macro�
Description�
�
PayLoad�
Helps to prevent reinstallation and spreading of the prank macro.�
�
AutoClose�
Will scan documents for the prank macros as you close them. If the prank macros are found it will clean them out of the document. If you have an already existing AutoClose macro, it will be renamed to AutoCloseScanOld.�
�



This document also includes a macro called CleanAll, which also runs automatically when you open this document (Scan831.doc). CleanAll will scan a specific folder and all subfolders (if selected), open each document and template in the search path that was saved after January 1, 1995, check for the prank macros and remove them if found.





If you want to run the CleanAll macro again to clean other paths, click Macro on the Tools menu, click CleanAll in the Macro Name list, and click Run. You can also copy the CleanAll macro from Scan831.doc to the Normal template by using the Organizer (to open the Organizer, click Macros on the Tools  menu and then click the Organizer button).





Disclaimer


Every attempt has been made to make this tool as comprehensive and foolproof as possible. However, it is possible that it will not provide 100-percent protection against the prank macros. Microsoft provides this macro code "as is" without warranty of any kind, either express or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.





More Information: All Platforms of Word


Close all other documents before opening the Scan Tool document.


When the CleanAll portion of the SCAN tool runs, it opens and closes all eligible documents. SCAN may close documents that are currently opened. To ensure you do not lose any work, close all other documents before opening SCAN Tool document or running CleanAll.





Prompt to convert template back to document.


Part of the prank in the prank macro is to change documents into document templates. This creates a problem with the File SaveAs command. When CleanAll finds a file that contains evidence of the prank macro, CleanAll removes the added macros and prompts for confirmation to convert the template back to a document. This prompt appears only if the file has no additional macros, AutoText entries, or key assignments. While these internal tests are good indications that the template should be converted back to a document, there are other possible reasons that the file should remain a template. Because of these reasons, user confirmation is required to make the change.





Error Message: “WordBasic Error 53 - File Not Found.” 


The most likely reason for this error is in the rare case when the AutoOpen macro cannot locate the Normal template file. This might happen if your User Templates path does not contain the Normal template used by your Word session. Be sure that this setting points to the correct location of your Normal template. (To locate the User Templates setting, click Options on the Tools menu, and click the File Locations tab.)





Error Message: “The list of paths is full.” 


While scanning a large directory structure with many files, you may encounter the message  “The list of paths is full.”  This message indicates that Word for Windows cannot deal with the number of documents found. To work around this problem, scan smaller subdirectory structures or individual subdirectories by themselves (that is, clear the Scan Subdirectories check box).





Screen flashes when macros are run.


When Internet Assistant is installed, you may notice a some flashing on the screen as the CleanAll macro opens and closes documents. 





File cannot be opened.


If a file cannot be opened or saved, there may be insufficient permissions or an incorrect password, or another user may have the file open.





Converter or style sheet cannot be found.


When CleanAll opens a document, you may get an error message indicating that a converter or style sheet could not be found. You can ignore this error message; most likely, the document was created with an earlier version of Word for Windows, Word for the Macintosh, or Word for MS-DOS.





Not all documents are found.


The CleanAll macro searches only for those files that have a save date later than January 1, 1995. The reason for this is that evidence of the prank macro was  first encountered well into mid-1995.





More Information: Word for Windows 95


During the first cycle of the CleanAll macro, you will not see the dialog box showing the current status of the search.


It is recommend that the Start, Documents Menu be cleared prior to running the macro. This is done by right mouse clicking on task bar, choosing Properties, selecting the Start Menu Programs tab, choosing the Clear button.


If you have any shortcuts to documents in your Start, Documents Menu, the macro will follow them to their origin, which can cause problems if you no longer have access to them (e.g. file has been deleted, network share that the file resides on is no longer available, etc.).





More Information: Word for the Macintosh


In Word for the Macintosh, the Directory box in the Batch Macro Cleanup dialog box shows Macintosh HD as the default. If your hard disk has a different name, you'll need to remove the "Macintosh HD:" text and type the name of your hard disk instead.





How to obtain this file


This file, Scan831.doc, is included with a Microsoft Application Note titled “Prank Macros:  Cleanup and Prevention.” For Word running on Windows platforms, the Application Note number is WD1215. For Word for the Macintosh, the Application Note number is MW1222. You can obtain this Application Note from the following sources:





CompuServe, Genie, and Microsoft Partner Network (MSPN)


Microsoft Download service(MSDL)


The Internet (Microsoft anonymous ftp server)


Microsoft FastTips technical Library


Microsoft Product Support Services 








